Меню сайта
Категории раздела
Администрирование и Конфигурирование [6]
Администрирование




Строительная компания Красный слон














Яндекс.Погода

Рейтинг@Mail.ru






Анализ сайта ihelp23.ru

CCleaner - System Optimization
Главная » Статьи » » Администрирование и Конфигурирование

Сообщение о не хватки товаров в документе РеализацияТоваровУслуг
РеализацияТоваровУслуг (РТУ)
      Была поставлена задача в РТУ выводить сообщение если определенного товара нет в наличии.
      Решил данную проблему следующим образом 
взял фунцию с данного ресурса http://infostart.blog-buh.ru/public/362042/. 
      Открываем Конфигуратор - Документы -РеализацияТоваровУслуг. Открываем "Открыть модуль объекта" вставляем функцию
Функция ПоискОстатковПоСкладу(Номенклатура, ДатаДокумента, СкладДокумента)

 ОстатокНаТекущийМомент = 0;
 
 ПоискОстатков = Новый Запрос();
 ПоискОстатков.Текст = "ВЫБРАТЬ
 | ТоварыНаСкладахОстатки.Номенклатура КАК Номенклатура,
 | ТоварыНаСкладахОстатки.КоличествоОстаток КАК Количество
 |ИЗ
 | РегистрНакопления.ТоварыНаСкладах.Остатки(
 | &Дата,
 | Номенклатура = &Номенклатура
 | И Склад = &Склад) КАК ТоварыНаСкладахОстатки";
 
 ПоискОстатков.УстановитьПараметр("Номенклатура", Номенклатура); 
 ПоискОстатков.УстановитьПараметр("Склад", СкладДокумента);
 ПоискОстатков.УстановитьПараметр("Дата",Новый Граница(ДатаДокумента, ВидГраницы.Включая));
 
 ОстаткиПоПозиции = ПоискОстатков.Выполнить().Выгрузить();
 
 Если ОстаткиПоПозиции.Количество()>0 Тогда
 ОстатокНаТекущийМомент = ОстаткиПоПозиции[0].Количество;
 Иначе
 ОстатокНаТекущийМомент = 0;
 КонецЕсли; 
 
 Возврат ОстатокНаТекущийМомент;

КонецФункции

Далее ишем в процедуру "ПередЗаписью" и вставляем следующий текст. 
// Доработка Артем 20170516
    ДокРеал = Документы.РеализацияТоваровУслуг;
    ТоварыДокумента = Товары;
     
    Для Каждого Стр ИЗ ТоварыДокумента Цикл
        КоличествоНоменлатурыНаСкладе = ПоискОстатковПоСкладу(Стр.Номенклатура, Дата, Склад);
        СколькоНехватает = КоличествоНоменлатурыНаСкладе - Стр.Количество;
            Если СколькоНехватает < 0 Тогда
                      //Отказ=Истина;
                 Сообщить(Строка(Стр.Номенклатура)+" не хватает "+Строка(СколькоНехватает*(-1)), СтатусСообщения.ОченьВажное);
            КонецЕсли;    
    КонецЦикла;
        //Доработка Артем 20170516Если расскоментировать "//Отказ=Истина;", то документ не сохранится пока не будет не отрицательного значения. 
Категория: Администрирование и Конфигурирование | Добавил: ITtech23 (16.05.2017) | Автор: Ihelp23.ru E W
Просмотров: 152 | Теги: РеализацияТоваровУслуг, рту, 1C, | Рейтинг: 5.0/2
Всего комментариев: 0
avatar


Формула 27 Краснодар Место встречи Дальневосточников

Строительная компания Красный слон

thumb

FL.ru – фриланс сайт удаленной работы №1. Поиск удаленной работы, фрилансеры.

thumb

Клуб студентов "Технарь". Расчетные работы, курсовые, дипломы, лабораторные работы, чертежи. Все что может понадобиться студенту технарю! Студенческий форум!





Качественное создание сайтов

Cloudim - онлайн консультант для сайта бесплатно.


Расскажи друзьям:



Узнай свой IP адрес
Проверить