Меню сайта
Категории раздела
Администрирование и Конфигурирование [6]
Администрирование




Строительная компания Красный слон














Яндекс.Погода

Рейтинг@Mail.ru






Анализ сайта ihelp23.ru

CCleaner - System Optimization
Главная » Статьи » » Администрирование и Конфигурирование

УниверсальныйПередаточныйДокумент, печать доверенности
УниверсальныйПередаточныйДокумент, печать доверенности без счет-фактуры.
Как то Б/У достало заполнять ручками доверенности, и поставили вопрос, а почему бы не автоматизировать данный процесс.
      Полистал интернет результатов не было. Пришлось делать самому. 
      Все оказалось гораздо проще. Все есть в 1С. только надо чуть ручками в макете доработать, а именно добавить параметр "Доверенность".
Можно еще изменить в конфигураторе "Общие" - "Общие модули" - "УчетНДС" находим данную процедуру и закоментируем часть строки "+ ДанныеДокумента.Доверенность". Все теперь будет красиво выводится. 

Процедура ЗаполнитьОснование(ДанныеДокумента, ДанныеДляПечати) Экспорт
    Основание = Строка(ДанныеДокумента.ДоговорКонтрагента);
    РасшифровкаОснования = ДанныеДокумента.ДоговорКонтрагента;
    Если ДанныеДокумента.Свойство("Доверенность") И ЗначениеЗаполнено(ДанныеДокумента.Доверенность) Тогда
        Основание = Основание + ?(ПустаяСтрока(Основание), "", "; ");  // + ДанныеДокумента.Доверенность
    Иначе
        ВедениеВзаиморасчетов = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ДанныеДокумента.ДоговорКонтрагента, "ВедениеВзаиморасчетов");
        Если ВедениеВзаиморасчетов = Перечисления.ВедениеВзаиморасчетовПоДоговорам.ПоЗаказам
            ИЛИ ВедениеВзаиморасчетов = Перечисления.ВедениеВзаиморасчетовПоДоговорам.ПоСчетам Тогда
            
            ДокументОснование = Неопределено;
            ДанныеДокумента.Свойство("ДокументОснование", ДокументОснование);
            
            Если ЗначениеЗаполнено(ДокументОснование) Тогда
                Если ДокументОснование.Метаданные().Реквизиты.Найти("Сделка") <> Неопределено Тогда
                    Сделка = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ДокументОснование, "Сделка");
                    Если ЗначениеЗаполнено(Сделка) Тогда
                        Основание = ОбщегоНазначения.СформироватьЗаголовокДокумента(Сделка, Строка(Сделка.Метаданные().Синоним));
                        РасшифровкаОснования = Сделка;
                    КонецЕсли;
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
    ДанныеДляПечати.Вставить("Основание", Основание);
    ДанныеДляПечати.Вставить("РасшифровкаОснования", РасшифровкаОснования);
КонецПроцедуры


Категория: Администрирование и Конфигурирование | Добавил: ITtech23 (12.05.2017) | Автор: Ihelp23.ru E W
Просмотров: 145 | Теги: 1С., УПД, УПД доверенность | Рейтинг: 5.0/2
Всего комментариев: 0
avatar


Формула 27 Краснодар Место встречи Дальневосточников

Строительная компания Красный слон

thumb

FL.ru – фриланс сайт удаленной работы №1. Поиск удаленной работы, фрилансеры.

thumb

Клуб студентов "Технарь". Расчетные работы, курсовые, дипломы, лабораторные работы, чертежи. Все что может понадобиться студенту технарю! Студенческий форум!





Качественное создание сайтов

Cloudim - онлайн консультант для сайта бесплатно.


Расскажи друзьям:



Узнай свой IP адрес
Проверить